Flow artifact naming
Do you guys find the current names of the definition objects straightforward when compared to the flow execution objects?
e.g. Flow, State, Transition, are all DEFINITION objects, singletons.
FlowExecution, FlowSession are EXECUTION objects.
Currently the definition objects are referenced from client code (views, etc.) like _flowId and _currentStateId. The execution object is referenced _flowExecutionId.
Do you guys find this clear? Would you prefer to see _flowDefinitionId with _flowExecutionId? Is _flowInstanceId better than _flowExecutionId?
If we rename _flowId to _flowDefinitionId that probably also means we rename Flow to FlowDefinition, State to StateDefinition, etc. I kind of like the short names, but want things to be as clear as possible.
Thoughts? What would be your names? This is set in stone at 1.0 final so we want to make sure we consider any option to make clarifications now.
Core Spring Development Team