Sorry about that - the 'XmlPayload' was removed from those classnames.
Author: Mark Fisher <firstname.lastname@example.org>
Date: Mon Dec 14 00:26:02 2009 +0000
Removed 'XmlPayload' from the names of 'XmlPayloadUnmarshallingTransformer' and 'XmlPayloadMarshallingTransformer' since the former can now return a Message instance and the latter now accepts a boolean to specify whether only the payload should be passed to the marshaller or the entire Message.
I'll add a note to the Wiki.
Gary P. Russell
Spring Integration Team
SpringSource, a division of VMware