Nov 26th, 2012, 07:12 PM
1.1.X Naming Conventions for appId/appSecret?
I know the 1.1.x API is still in flux. As a result, there are some naming inconsistencies with the appId/appSecret that I'd like to get your take on so that I can better align my API with the direction you are taking. For example:
EnableTwitter - appId, appSecret
TwitterConnectionFactory - consumerKey, consumerSecret
TwitterServiceProvider - consumerKey, consumerSecret
EnableFacebook.java - appId, appSecret
FacebookConnectionFactory - appId, appSecret
FacebookServiceProvider - appId, appSecret
EnableLinkedIn.java - appId, appSecret
LinkedInConnectionFactory - consumerKey, consumerSecret
LinkedInServiceProvider - accessToken, secret
OAuth2Template - clientId, clientSecret
Based on the Facebook API, it looks like you are moving to use appId/appSecret. Is this where you are going?