Taken from the following thread.
I was referring to that when I asked about the JIRA.Alan said
The service command currently accepts the one entity, but it could be changed to accept multiple entities. However, you wouldn't get command line completion - it would be similar to the --includeTables on the database reverse engineer command, due to shell limitations. We could also just let the service command be able to be run several times, each with a different entity, and this entity would be added to the annotation. Raise a jira request if you like.
I added in a related but different scenario:
(Perhaps a better name for the method would be calculateTotalAccountBalance.) I assume to implement this I would want the service interface to not be tied to ANY entity(a service interface without even one entity), and only the implementation to be tied to them. Then one would manually add the getTotalAccountBalance to the service interface. The service interface might deal with an Account interface...Is there any plans for having something like:
If I would want to have a service with a getTotalAccountBalance method which in the implementation only would based on the business logic refer to combination of different entity types and their instances. Meaning that the clients would only be exposed to the method without having any clue as to the details of the implementation; only the service implementation tied to the entities. And/or perhaps a service referring to other services and not to entities...
Currently the service command operates on one and only one entity, there was discussion about having that be one or more, I'm interested in a service linked at the interface to no entities and only the implementation linked to the entities.