Jan 19th, 2011, 02:49 AM
The mvc:annotation-driven element already defines an AnnotationMethodHandlerAdapter bean among others. Hence you're currently providing a second instance of it and that's not really what you want. If you need to customize things like message converters you'll need to use configuration like what scram posted above instead of the of mvc namespace.
There are tickets in JIRA already for improving the mvc namespace to allow registration of additional converters (see SPR-7091, SPR-7504, SPR-7191).
Tags for this Thread