View Full Version : What JDK/Spring version are supported?
Jan 26th, 2008, 02:17 AM
I didn't find the answer in the home web site and reference.
Does it need Java 5?
Jan 26th, 2008, 07:21 AM
Yes, Spring Integration does require Java 5 or later. I will be sure to make that more explicit in the reference manual before the next release.
Jan 27th, 2008, 07:16 AM
It appears Spring Integration requires Spring 2.5. Will it be possible to use with Spring 2.0 ?
Jan 29th, 2008, 09:17 AM
Spring 2.5+ will be required for Spring Integration 1.0. We will be taking advantage of new 2.5 features (e.g. extended annotation support and OSGi-compliance). Also, we would expect that by the time of the Spring Integration 1.0 final release, the only reason not to upgrade to Spring 2.5.x would be the need for Java 1.3 support - in which case Spring Integration would not be an option anyways.
Powered by vBulletin® Version 4.2.1 Copyright © 2013 vBulletin Solutions, Inc. All rights reserved.